IIS Manager in Windows 10
up vote 46 down vote favorite
4

How do you open IIS (Internet Information Services) Manager using Windows 10?

I have installed the deveolper preview of WIndows 10 and cant seem to find IIS Manager? It is not in Control Panel > Administrative Tools.

When I browse to the folder C:\Windows\System32\inetsrv it is empty.

I did a full search of my hard drive to find inetmgr.exe and found three copys and none of them would open, when I tried to open them it says "This App cannot Run on your PC" To find a version of the App that works contact the publisher.

I know IIS works because I have ran local ASP.net apps through VisualStudio but I cant seem to find a way to launch IIS Manager to do some configurations for a site.

Any one know anything about this??????



StackOverflow

MattyMerrix elaborated very well, i want to add that if you can see "ask me any thing" box i.e. Cortana "the intelligent software" at the task bar then there is no need to press the windows key.enter image description here



  • Run appwiz.cpl - brings up Programs and Features
  • Choose "Turn Windows Features On/Off"
  • Select the IIS Services you need


Actually you must make sure that the IIS Management Console feature is explicitly checked. On my win 10 pro I had to do it manually, checking the root only was not enough!



Launch Windows Features On/Off and select your IIS options for installation.

For custom site configuration, ensure IIS Management Console is marked for installation under Web Management Tools.



@user1664035 & @Attila Mika's suggestion worked. You have to navigate to Control Panel -> Programs And Features -> Turn Windows Features On or Off. And refer to the screenshot. You should check IIS Management console.Screenshot



Under the windows feature list, make sure to check the IIS Management Console



after turning IIS on (by going to Windows Features On/Off) type inetmgr in search bar or run



I encountered the same problem after I upgraded to WIN 10 from 7

if it is IIS10 which is blocking your port 80 (which is the default port for apache sever)

Easiest solution I found on stack overflow is

1)Go to start, type in services.msc

2)Scroll down in the Services window to find the World Wide Web Publishing Service.

3)Right click on it and select Stop.

4) go to wamp icon (in icon tray), go to apache->service->install service

5) do same for mysql , mysql->service->install service

6) then apache->service->start service

7) mysql->service->start service

Woallah...

Wamp starts working

turns green

hope it helps :)